Board index » Setup And Technical




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Rickenbacker 620 problem
 Post Posted: Thu Jan 11, 2018 4:16 pm 
Offline

Joined: Wed Jan 10, 2018 8:36 am
Posts: 2
Hello, this is my first post here.. I purchased a rickenbacker 620 mapleglo (and i am happy with it), second hand, 2008 model, mint condition and everything seems untouched.
But... i have one small problem. When i roll off any of the two volumes the sound is turned off (as it should) but if any overdrive is "on" i still can hear sound coming from the amp!! Not loud, but the sound is still there...
This happens with any of the pickups, BUT, when i turn both pickup volumes down then the sound finally disappears!
So only when both volume pots are rolled off, the sound is off.
I suppose this is not normal... i read somewhere (about a completely different guitar, a tele) that this is happening because of bad grounding...
I removed the pickguard today, from what i can tell everything seems ok and untouched. I took some photos, if you guys think i should post them then i will.
Any ideas? I am so happy with my new guitar and this "bug" is ruining it.. this is my first ever rickenbacker after soooo many guitars.

(sorry for my english)


Top 
 Profile  
 
 Post subject: Re: Rickenbacker 620 problem
 Post Posted: Mon Jan 15, 2018 3:53 pm 
Offline

Joined: Wed Jan 10, 2018 8:36 am
Posts: 2
Any ideas...?
You can check the photos below


Attachments:
IMG_20180111_090320.jpg [164.12 KiB]
Not downloaded yet
IMG_20180111_083821.jpg [160.42 KiB]
Not downloaded yet
Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » Setup And Technical


Who is online

Users browsing this forum: No registered users and 9 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Register    Login    Forum    Search    FAQ
X