Rickenbacker International Corporation - Forum
http://www.rickenbacker.com/forum/

Need Help - Ric 620 squealing with High Gain Amp
http://www.rickenbacker.com/forum/viewtopic.php?f=2&t=15011
Page 1 of 1

Author:  rumble66 [ Mon Mar 19, 2012 6:14 pm ]
Post subject:  Need Help - Ric 620 squealing with High Gain Amp

I love my Ric 620 but I found the stock Hi Gain single coils too noisy with my Marshall JCM 800 cranked up. The also squealed a lot. So I swapped out the Hi Gains for HB1 Humbuckers. Also installed 500k pots per suggestions.

I love the thickness of the new pickups and the noise is gone but the guitar still squeals like crazy. I have to roll off the volume and tones to get it under control. I don't understand why this happens. I plug in my old SG and it is find. I plug in the 620 and unless I have everything rolled off just so, I get this piercing feedback. Any ideas what I can do to stop this?

Author:  Ain'tGotNoPokemon [ Tue Mar 20, 2012 12:47 pm ]
Post subject:  Re: Need Help - Ric 620 squealing with High Gain Amp

One problem I sometimes have with a Ric or a Jazzmaster, which have that cool bridge design, is that the strings behind the bridge will sometimes ring with high gain.

Another thing to take into consideration is that the lighting in the room may affect the pickups to an extent. Try playing in the dark and see if it happens.

Author:  JohnHall [ Tue Mar 20, 2012 2:56 pm ]
Post subject:  Re: Need Help - Ric 620 squealing with High Gain Amp

Di you change the capacitors by any chance? Sometimes the wrong type or a bad one will cause this also. Ceramic caps are the worst in this regard and the plastic type are preferred.

Author:  rumble66 [ Tue Mar 20, 2012 6:25 pm ]
Post subject:  Re: Need Help - Ric 620 squealing with High Gain Amp

Thanks for the reply, Mr. Hall. I didn't change anything but the pots when I installed the HB1's. It's so frustrating as the guitar has such great tone and sweet sustain but it just can't seem to handle the high gain. As soon as I turn up the preamp on the Marshall, it starts that high pitch squeal. I have to roll everything 1/2 off even the 5th knob. Anything full up will cause the ruckus. I know it's not the amp because with the same setting, the old SG is fine.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/