Board index » Setup And Technical




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Rickenbacker 620 problem
 Post Posted: Thu Jan 11, 2018 4:16 pm 
Offline

Joined: Wed Jan 10, 2018 8:36 am
Posts: 3
Hello, this is my first post here.. I purchased a rickenbacker 620 mapleglo (and i am happy with it), second hand, 2008 model, mint condition and everything seems untouched.
But... i have one small problem. When i roll off any of the two volumes the sound is turned off (as it should) but if any overdrive is "on" i still can hear sound coming from the amp!! Not loud, but the sound is still there...
This happens with any of the pickups, BUT, when i turn both pickup volumes down then the sound finally disappears!
So only when both volume pots are rolled off, the sound is off.
I suppose this is not normal... i read somewhere (about a completely different guitar, a tele) that this is happening because of bad grounding...
I removed the pickguard today, from what i can tell everything seems ok and untouched. I took some photos, if you guys think i should post them then i will.
Any ideas? I am so happy with my new guitar and this "bug" is ruining it.. this is my first ever rickenbacker after soooo many guitars.

(sorry for my english)


Top 
 Profile  
 
 Post subject: Re: Rickenbacker 620 problem
 Post Posted: Mon Jan 15, 2018 3:53 pm 
Offline

Joined: Wed Jan 10, 2018 8:36 am
Posts: 3
Any ideas...?
You can check the photos below


Attachments:
IMG_20180111_090320.jpg [164.12 KiB]
Not downloaded yet
IMG_20180111_083821.jpg [160.42 KiB]
Not downloaded yet
Top 
 Profile  
 
 Post subject: Re: Rickenbacker 620 problem
 Post Posted: Wed Jan 17, 2018 7:37 am 
Offline

Joined: Sun Oct 08, 2006 6:07 am
Posts: 3768
Please try this: put the selector switch in either the "up" or "down" position for each pickup separately. Then turn that pickup's volume control all the way down and see if you still have the same issue.

Also, make sure the contacts are clean and making good contact when you run your cord in the mono jack as well as the tip-ring-sleeve cord in the Ric-O-Sound jack.

Volume knobs do not actually turn anything "off" when turned all the way down. Turning down a volume knob only increases the load attenuating the signal until it does not register to the input of the amplifier. There may be some residual signal, which is not audible with clean gain circuits. But an overdrive is just that: cranking the gain up until everything clips. So it does not surprise me that you may have some residual signal buried in the background noise of the high-gain overdrive pedal. This is the way all conventional electric guitars work.


Top 
 Profile  
 
 Post subject: Re: Rickenbacker 620 problem
 Post Posted: Wed Jan 17, 2018 11:13 am 
Offline

Joined: Wed Jan 10, 2018 8:36 am
Posts: 3
iiipopes wrote:
Please try this: put the selector switch in either the "up" or "down" position for each pickup separately. Then turn that pickup's volume control all the way down and see if you still have the same issue.

That's exactly what i do. In each pickup i turn the volume down and that's when i have that issue of still hearing sound. But when i turn both volume pots down (regardless of which pickup i use) the sound is finally off.

Contacts seem clean to me, and my cables/jacks are good (i also use wireless occasionally, still the same issue)

iiipopes wrote:
So it does not surprise me that you may have some residual signal buried in the background noise of the high-gain overdrive pedal. This is the way all conventional electric guitars work.

Ok, then why is this never happens with any other guitar (with even higher gain pickups, les paul i.e., even with a supertrat with extra HIGH gain?). And why the sound turns down when i roll off both volume pots? The same cables, pedals, amps, but when i turn the volume down in any guitar the sound goes "off" but with the ric 620 i still hear sound!
Note, i am not talking about hum, or any kind of normal noise. It's guitar sound, i can play chords, i can hear them (not loud and only when an overdrive is "pushing" the signal).
I believe that something is wrong with the electronics...
Any ideas would be very helpful to me :) thanks for your reply


Top 
 Profile  
 
 Post subject: Re: Rickenbacker 620 problem
 Post Posted: Wed Sep 05, 2018 3:52 pm 
Offline

Joined: Fri Feb 09, 2018 9:06 am
Posts: 27
My personal opinion is that the design was purposely made this way to allow a certain amount of tonal "sweetening". The circuit "bleeds" some of the tone from the unselected pickup group to the selected pickups to create more body to the tone. I like to roll off the unselected pickup, at times, to create a cleaner sound. But it generally sounds better with the "bleed", I think.

Isn't this part of what adds to the complexity of the sound and part of the blending 5th knob function?


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 5 posts ] 

Board index » Setup And Technical


Who is online

Users browsing this forum: No registered users and 10 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Register    Login    Forum    Search    FAQ
X