Board index » Just Basses




Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 8:28 am 
Offline

Joined: Wed Feb 08, 2006 2:00 pm
Posts: 23
Location: Virginia
I think I may have killed the pickup on my Ric! I'm not sure, but the E string sounds completely dead...there's no ring to it at all...it just goes dead...anyone have any clue as to why this is happening? I've tried it on different amps and with different cables...and changed the settings on the bass a million times over...ANY HELP IS GREATLY APPRECIATED!


Thanks a lot in advance *crosses fingers and prays*


peace n' love



~Bill


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 8:33 am 
Offline

Joined: Mon Oct 17, 2005 2:00 pm
Posts: 1677
Location: San Francisco Bay Area, Northern California
Have you tried changing the strings? I'm sorry if it sounds stupid, but my strings eventually start sounding dead to me after they've been on a while.


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 8:42 am 
Offline

Joined: Wed Feb 08, 2006 2:00 pm
Posts: 23
Location: Virginia
Gar...I'm probably an idiot...lol...that's probably it..but they've only been on for maybe a month and a half...I play everyday for two hours or so, but I wipe 'em thouroughly every time...and the last set lasted longer (I think)...but that might be it...and I don't know why I didn't think of that...thakns a lot..if it's not just an old set of strings, would it be a broken pole piece? I'm not sure, and I'm no tech...but that's all I can think of.


thanks a lot


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 9:03 am 
Offline

Joined: Tue Sep 06, 2005 1:00 pm
Posts: 497
Location: South Side of the Sky
Blackbird89,

Are you not getting any sound at all off your E string or is the E string just sounds like the string is just dead sounding, I guess what I'm trying to say is I've never heard on a Rickenbacker where there is no sound at all on one string but hey I guess there is always a first time, but anyways I can understand if your E string is just dead sounding from sweat and useage and that would cause maybe not as loud volumewise as with the other strings but the way you are describing it, it sounds like the string isn't producing any sound at all as in not being amplified, If i where you you shouild definatley call Rickenbackers customer service line first thing Mon. and maybe you should check with Dale Fortune who regularly post on the restoration section of the forum and ask him for a professional opinion also, that definatley sounds weird, maybe it is something wrong with the E string pole piece, I have to tell you that is definatley the first time I have ever heard of anything like that before.
Good Luck,

FISH


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 9:08 am 
Offline

Joined: Wed Feb 08, 2006 2:00 pm
Posts: 23
Location: Virginia
nahh, the more I think about it, the more I feel like a retard...'cause it's most likely just an old string. But the only trouble with that is that I use the G and D strings more than anything...and they still sound fine..but maybe all that Metallica I played for a while killed it...definetely sounds like an old string, but these are almost new...I'll have to try changing tomorrow...I guess I'll try those Elixir Gunk-resistant strings...thanks a lot, guys! I really do appreciate it


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 9:09 am 
Offline
User avatar

Joined: Tue Aug 09, 2005 1:00 pm
Posts: 2592
Location: The Rickenroom
Is there any sound at all? At least a thump? If you are at least getting a thump, maybe you've not realized that you raised the mute. Maybe someone else was turning the thumbscrew on the mute. Take a close look, you'll see if the mute os contacting the E string. If so,turn the thumbscrew on the E string side counterclockwise (to the left} a couple of turns and see what happens. Hopefully that's all it is.
If one or both pickups are too close to the strings, it can shorten their sustain.
A new set of strings wouldn't hurt, but I've seen some pretty dull, worn bass strings in my playing years and they have all had at least some sustain.

_________________
Throw that piece of firewood where it belongs and get yourself a Rickenbacker!


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 9:22 am 
Offline

Joined: Tue Sep 06, 2005 1:00 pm
Posts: 497
Location: South Side of the Sky
Another thing you might check on also is your pickup height on your pickups, you might need to raise the bass side of both your pickups up a little bit or lower the D and G string sides of both your pickups to get equal volume across the whole spectrum.


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 10:34 am 
Offline

Joined: Tue Aug 16, 2005 1:00 pm
Posts: 879
Location: boston,ga
HI, Which p/u is it, is it the neck or the treble. Have you tried moving the toggle switch to see if both p/us are working.. I like the mute thing also, when it touches the string, you will not have any ring to the string.:)


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sat Feb 11, 2006 11:39 pm 
Offline

Joined: Wed Feb 08, 2006 2:00 pm
Posts: 23
Location: Virginia
Ok, yea, it's probably the mute thing...'cause I do put my hand right over the thumb screw when I play harmonics, and I've been playing Portrait of Tracy by Jaco lately...so that's probably it. Thanks a lot for all the help! I'll let y'all know if none of those solutions works.


Thanks again to everyone!



Peace n' Love


Top 
 Profile  
 
 Post subject: Re: Help! Please! Emergency!!
 Post Posted: Sun Feb 12, 2006 1:08 am 
Offline

Joined: Wed Feb 08, 2006 2:00 pm
Posts: 23
Location: Virginia
ok, well, adjusting the mute didn't help...I'm hoping and praying that new strings will :/ ...I'll let y'all know


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

Board index » Just Basses


Who is online

Users browsing this forum: No registered users and 14 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Register    Login    Forum    Search    FAQ
X